## START: Set by rpmautospec
## (rpmautospec version 0.3.8)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by go2rpm 1.9.0
%bcond_without check
%global debug_package %{nil}
%global gotestflags -short

# https://gitlab.com/cznic/sqlite
%global goipath         modernc.org/sqlite
%global forgeurl        https://gitlab.com/cznic/sqlite
Version:                1.23.1
%global tag             v%{version}

%gometa -f

%global common_description %{expand:
Package sqlite is a CGo-free port of SQLite/SQLite3.

SQLite is an in-process implementation of a self-contained, serverless, zero-
configuration, transactional SQL database engine.}

%global golicenses      LICENSE SQLITE-LICENSE
%global godocs          examples AUTHORS CONTRIBUTORS README.md

Name:           %{goname}
Release:        %autorelease
Summary:        A CGo-free port of SQLite/SQLite3

License:        BSD-3-Clause
URL:            %{gourl}
Source:         %{gosource}

%description %{common_description}

%gopkg

%prep
%goprep
%autopatch -p1

%generate_buildrequires
%go_generate_buildrequires

%install
%gopkginstall

%if %{with check}
%check
%gocheck
%endif

%gopkgfiles

%changelog
## START: Generated by rpmautospec
* Mon Dec 11 2023 Link Dupont <linkdupont@fedoraproject.org> - 1.23.1-1
- Uncommitted changes
## END: Generated by rpmautospec