%define name            cryptopANT
%define version         1.2.2
BuildRoot:              %{_tmppath}/%{name}-%{version}-build
Summary:                IP address anonymization library and utils
License:                GPL
URL:                    http://ant.isi.edu/software/cryptopANT/index.html
Name:                   %{name}
Version:                %{version}
Release:                1%{?dist}
Source:                 %{name}-%{version}.tar.gz
Packager:               yuri@isi.edu
Prefix:                 /usr
Group:                  System/Libraries
BuildRequires:          gcc glibc-headers 
BuildRequires:          openssl-devel
BuildRequires:          autoconf automake libtool
Requires:               openssl

%description
cryptopANT is a library for ip address anonymization.  It implements a
widely used prefix-preserving technique known as "cryptopan".  This is
ANT's project implementation of this technique for anonymization of ipv4
and ipv6 addresses.

%prep
%setup -q

%build
%configure --with-scramble_ips
make

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=%{buildroot}
libtool --finish %{_libdir}

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-,root,root,-)
%{_includedir}/*
%{_mandir}/man3/*
%{_libdir}/*.so
%{_libdir}/*.so.*
%{_libdir}/*.a
%exclude %{_libdir}/*.la
%{_bindir}/scramble_ips
%{_mandir}/man3/*