## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 27
# * Deactivate tests because of a missing dev-dependency (gix-testtools)
# * See https://github.com/Byron/gitoxide/discussions/900 for more information
%bcond check 0
%global debug_package %{nil}

%global crate gix-pathspec

Name:           rust-gix-pathspec
Version:        0.9.0
Release:        %autorelease
Summary:        Library for dealing with magical pathspecs used by gix

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/gix-pathspec
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
A crate of the gitoxide project dealing magical pathspecs.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
# We exclude the tests directory because they contain bash scripts
# and the automatic Requires detection falsely adds bash as a required dependency.
# Tests are disabled anyway so this should have no effect.
%exclude %{crate_instdir}/tests

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Wed Jan 22 2025 blinxen <h-k-81@hotmail.com> - 0.9.0-1
- Uncommitted changes

* Tue Sep 10 2024 blinxen <h-k-81@hotmail.com> - 0.7.7-1
- Update to version 0.7.7 (rhbz#2307396)

* Thu Jul 25 2024 blinxen <h-k-81@hotmail.com> - 0.7.6-1
- Update to version 0.7.6 (rhbz#2299580)

* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

* Sun Jun 23 2024 blinxen <h-k-81@hotmail.com> - 0.7.5-1
- Update to version 0.7.5 (rhbz#2282456)

* Tue Apr 23 2024 Fabio Valentini <decathorpe@gmail.com> - 0.7.4-1
- Update to version 0.7.4; Fixes RHBZ#2274902

* Fri Apr 05 2024 blinxen <h-k-81@hotmail.com> - 0.7.2-1
- Update to version 0.7.2 (rhbz#2253273)

* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Fri Oct 13 2023 blinxen <h-k-81@hotmail.com> - 0.4.0-1
- Update to version 0.4.0

* Wed Sep 27 2023 blinxen <h-k-81@hotmail.com> - 0.2.0-1
- Initial package (rhbz#2241049)
## END: Generated by rpmautospec