%global modulename is-number

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-is-number
Version:        3.0.0
Release:        1%{?dist}
Summary:        Returns true if the value is a number. comprehensive tests.

License:        MIT
URL:            https://github.com/jonschlinkert/is-number
Source0:        https://registry.npmjs.org/is-number/-/is-number-3.0.0.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(kind-of) >= 3.0.2 with npmlib(kind-of) < 4.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
Returns true if the value is a number. comprehensive tests.

%package 3.0.0
Summary:        Returns true if the value is a number. comprehensive tests.


%description 3.0.0
Returns true if the value is a number. comprehensive tests.

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc README.md
%license LICENSE
%{nodejs_dir}/%{modulename}

%files 3.0.0
%doc README.md
%license LICENSE
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Tue Nov 27 2018 npm2srpm <dshea@redhat.com> - 3.0.0-1
- Package automatically generated by npm2srpm