%global modulename to-vfile

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-to-vfile
Version:        4.0.0
Release:        1%{?dist}
Summary:        Create a vfile from a file-path

License:        MIT
URL:            https://github.com/vfile/to-vfile#readme
Source0:        https://registry.npmjs.org/to-vfile/-/to-vfile-4.0.0.tgz



BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(is-buffer) >= 2.0.0 with npmlib(is-buffer) < 3.0.0))
BuildRequires:  ((npmlib(vfile) >= 3.0.0 with npmlib(vfile) < 4.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
Create a vfile from a file-path

%package 4.0.0
Summary:        Create a vfile from a file-path


%description 4.0.0
Create a vfile from a file-path

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr lib %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
%{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc readme.md
%license LICENSE
%{nodejs_dir}/%{modulename}

%files 4.0.0
%doc readme.md
%license LICENSE
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Wed Dec 5 2018 npm2srpm <dshea@redhat.com> - 4.0.0-1
- Package automatically generated by npm2srpm