%global modulename safer-buffer

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-safer-buffer
Version:        2.1.2
Release:        1%{?dist}
Summary:        Modern Buffer API polyfill without footguns

License:        MIT
URL:            https://github.com/ChALkeR/safer-buffer#readme
Source0:        https://registry.npmjs.org/safer-buffer/-/safer-buffer-2.1.2.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch


Requires:       npmlib(%{modulename}) = %{version}

%description
Modern Buffer API polyfill without footguns

%package 2.1.2
Summary:        Modern Buffer API polyfill without footguns


%description 2.1.2
Modern Buffer API polyfill without footguns

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr dangerous.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr safer.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr tests.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc Porting-Buffer.md
%doc Readme.md
%license LICENSE
%{nodejs_dir}/%{modulename}

%files 2.1.2
%doc Porting-Buffer.md
%doc Readme.md
%license LICENSE
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Fri Nov 16 2018 npm2srpm <dshea@redhat.com> - 2.1.2-1
- Package automatically generated by npm2srpm