%global modulename wcwidth

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-wcwidth
Version:        1.0.1
Release:        1%{?dist}
Summary:        Port of C's wcwidth() and wcswidth()

License:        MIT
URL:            https://github.com/timoxley/wcwidth#readme
Source0:        https://registry.npmjs.org/wcwidth/-/wcwidth-1.0.1.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(defaults) >= 1.0.3 with npmlib(defaults) < 2.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
Port of C's wcwidth() and wcswidth()

%package 1.0.1
Summary:        Port of C's wcwidth() and wcswidth()


%description 1.0.1
Port of C's wcwidth() and wcswidth()

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr .npmignore %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr combining.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr test %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc Readme.md
%doc docs
%license LICENSE
%{nodejs_dir}/%{modulename}

%files 1.0.1
%doc Readme.md
%doc docs
%license LICENSE
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Fri Nov 16 2018 npm2srpm <dshea@redhat.com> - 1.0.1-1
- Package automatically generated by npm2srpm