%global modulename unified-lint-rule

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-unified-lint-rule
Version:        1.0.3
Release:        1%{?dist}
Summary:        Create a linting rule for a unified processors

License:        MIT
URL:            https://github.com/remarkjs/remark-lint/tree/master/packages/unified-lint-rule
Source0:        https://registry.npmjs.org/unified-lint-rule/-/unified-lint-rule-1.0.3.tgz



BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(wrapped) >= 1.0.1 with npmlib(wrapped) < 2.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
Create a linting rule for a unified processors

%package 1.0.3
Summary:        Create a linting rule for a unified processors


%description 1.0.3
Create a linting rule for a unified processors

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
%{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc readme.md
%{nodejs_dir}/%{modulename}

%files 1.0.3
%doc readme.md
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Thu Dec 6 2018 npm2srpm <dshea@redhat.com> - 1.0.3-1
- Package automatically generated by npm2srpm