%global modulename pump

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-pump
Version:        2.0.1
Release:        1%{?dist}
Summary:        pipe streams together and close all of them if one of them closes

License:        MIT
URL:            https://github.com/mafintosh/pump#readme
Source0:        https://registry.npmjs.org/pump/-/pump-2.0.1.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(end-of-stream) >= 1.1.0 with npmlib(end-of-stream) < 2.0.0))
BuildRequires:  ((npmlib(once) >= 1.3.1 with npmlib(once) < 2.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
pipe streams together and close all of them if one of them closes

%package 2.0.1
Summary:        pipe streams together and close all of them if one of them closes


%description 2.0.1
pipe streams together and close all of them if one of them closes

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr .travis.yml %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr test-browser.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr test-node.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc README.md
%license LICENSE
%{nodejs_dir}/%{modulename}

%files 2.0.1
%doc README.md
%license LICENSE
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Fri Nov 16 2018 npm2srpm <dshea@redhat.com> - 2.0.1-1
- Package automatically generated by npm2srpm