# Generated by go2rpm 1.8.2
%bcond_without check
%bcond_without bootstrap
%global debug_package %{nil}

%if %{with bootstrap}
%global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^golang\\(.*\\)$
%endif

# https://github.com/kubernetes-sigs/json
%global goipath         sigs.k8s.io/json
%global forgeurl        https://github.com/kubernetes-sigs/json
%global commit          f223a00ba0e27f539157f69f9c919c204ea7f40b

%gometa

%global common_description %{expand:
Golang JSON decoder supporting case-sensitive, number-preserving, and strict
decoding use cases.}

%global golicenses      LICENSE
%global godocs          CONTRIBUTING.md README.md SECURITY.md code-of-\\\
                        conduct.md

Name:           %{goname}
Version:        0
Release:        %autorelease -p
Summary:        Golang JSON decoder

License:        Apache-2.0
URL:            %{gourl}
Source:         %{gosource}

%description %{common_description}

%gopkg

%prep
%goprep

%if %{without bootstrap}
%generate_buildrequires
%go_generate_buildrequires
%endif

%install
%gopkginstall

%if %{without bootstrap}
%if %{with check}
%check
%gocheck
%endif
%endif

%gopkgfiles

%changelog
%autochangelog