# Generated by rust2rpm
# ENOTTY: stty: /dev/stderr: Inappropriate ioctl for device
%bcond_with check
%global debug_package %{nil}

%global crate terminal_size

Name:           rust-%{crate}
Version:        0.1.8
Release:        1%{?dist}
Summary:        Gets the size of your Linux or Windows terminal

# Upstream license specification: MIT OR Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/terminal_size
Source:         %{crates_source}
# Initial patched metadata
# - Remove Windows-only dependencies
Patch0:         terminal_size-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)

%global _description \
Gets the size of your Linux or Windows terminal.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Thu Apr 25 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.1.8-1
- Initial package