## START: Set by rpmautospec
%define autorelease(e:s:pb:) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{?dist}
## END: Set by rpmautospec

# Generated by rust2rpm 17
# Deactivate tests that are declared broken by upstream
# https://github.com/gtk-rs/gtk-rs-core/issues/64
%bcond_with check
%global debug_package %{nil}

%global crate gobject-sys

Name:           rust-%{crate}
Version:        0.14.0
Release:        %autorelease
Summary:        FFI bindings to libgobject-2.0

# Upstream license specification: MIT
License:        MIT
URL:            https://crates.io/crates/gobject-sys
Source:         %{crates_source}
# Download license files until next release
Source1:        https://raw.githubusercontent.com/gtk-rs/gtk-rs-core/master/COPYRIGHT
Source2:        https://raw.githubusercontent.com/gtk-rs/gtk-rs-core/master/LICENSE

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
FFI bindings to libgobject-2.0.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gobject-2.0) >= 2.48

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license COPYRIGHT LICENSE
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+dox-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dox-devel %{_description}

This package contains library source intended for building other packages
which use "dox" feature of "%{crate}" crate.

%files       -n %{name}+dox-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v2_54-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gobject-2.0) >= 2.54

%description -n %{name}+v2_54-devel %{_description}

This package contains library source intended for building other packages
which use "v2_54" feature of "%{crate}" crate.

%files       -n %{name}+v2_54-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v2_58-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gobject-2.0) >= 2.58

%description -n %{name}+v2_58-devel %{_description}

This package contains library source intended for building other packages
which use "v2_58" feature of "%{crate}" crate.

%files       -n %{name}+v2_58-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v2_62-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gobject-2.0) >= 2.62

%description -n %{name}+v2_62-devel %{_description}

This package contains library source intended for building other packages
which use "v2_62" feature of "%{crate}" crate.

%files       -n %{name}+v2_62-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v2_66-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gobject-2.0) >= 2.66

%description -n %{name}+v2_66-devel %{_description}

This package contains library source intended for building other packages
which use "v2_66" feature of "%{crate}" crate.

%files       -n %{name}+v2_66-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v2_68-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gobject-2.0) >= 2.68

%description -n %{name}+v2_68-devel %{_description}

This package contains library source intended for building other packages
which use "v2_68" feature of "%{crate}" crate.

%files       -n %{name}+v2_68-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
cp %{SOURCE1} COPYRIGHT
cp %{SOURCE2} LICENSE

%generate_buildrequires
%cargo_generate_buildrequires
echo 'pkgconfig(gobject-2.0) >= 2.48'

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Wed Jul 14 2021 Robert-André Mauchin <zebob.m@gmail.com> 0.14.0-2
- Uncommitted changes

* Thu Jul 01 2021 Rémi Lauzier <remilauzier@protonmail.com> 0.14.0-1
- Update to 0.14.0

* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> 0.10.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> 0.10.0-3
- Second attempt - Rebuilt for
  https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> 0.10.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Fri Jul 10 2020 Josh Stone <jistone@redhat.com> 0.10.0-1
- Update to 0.10.0

* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> 0.9.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Wed Jan 15 2020 Josh Stone <jistone@redhat.com> 0.9.1-2
- Fix new subpackage requirements.

* Wed Jan 15 2020 Josh Stone <jistone@redhat.com> 0.9.1-1
- Update to 0.9.1

* Tue Dec 10 2019 Josh Stone <jistone@redhat.com> 0.9.0-1
- Update to 0.9.0

* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> 0.8.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Sun Apr 28 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> 0.8.0-1
- Update to 0.8.0

* Tue Feb 12 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> 0.7.0-4
- Be more precise with dependencies

* Tue Feb 05 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> 0.7.0-3
- Adapt to new packaging

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> 0.7.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Thu Sep 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> 0.7.0-1
- Update to 0.7.0

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> 0.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Mon Mar 19 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> 0.6.0-1
- Update to 0.6.0

* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> 0.5.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> 0.5.0-2
- Rebuild for rust-packaging v5

* Wed Jan 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> 0.5.0-1
- initial import