# Generated by rust2rpm 17
# The test suite is not support on arm and i686
# https://github.com/rust-lang/packed_simd#platform-support
%ifnarch %{arm} %{ix86}
%bcond_without check
%endif
%global debug_package %{nil}

%global crate packed_simd_2

Name:           rust-%{crate}
Version:        0.3.5
Release:        1%{?dist}
Summary:        Portable Packed SIMD vectors

# Upstream license specification: MIT/Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/packed_simd_2
Source:         %{crates_source}
# Initial patched metadata
# Relax wasm-bindgen dependencies
# Replace libm dep with num-traits
# Bump paste to 1
Patch0:         packed_simd_2-fix-metadata.diff
# Indirectly update to libm 0.2
# Inspired by https://github.com/dimforge/alga/pull/93
# https://github.com/rust-lang/packed_simd/pull/335
Patch1:         0001-Indirectly-update-to-libm-0.2.patch
# To use newer cfg-if
# https://github.com/rust-lang/packed_simd/commit/db8810eea596e38ee3d95bbe00d61ad78f92e736
Patch2:         0001-Update-cgf-if-and-a-few-fix.patch
# To use newer paste
# https://github.com/rust-lang/packed_simd/pull/333
Patch3:         0001-Bump-paste-to-1.patch

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
Portable Packed SIMD vectors.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-APACHE LICENSE-MIT
%doc contributing.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+core_arch-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+core_arch-devel %{_description}

This package contains library source intended for building other packages
which use "core_arch" feature of "%{crate}" crate.

%files       -n %{name}+core_arch-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+into_bits-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+into_bits-devel %{_description}

This package contains library source intended for building other packages
which use "into_bits" feature of "%{crate}" crate.

%files       -n %{name}+into_bits-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+libcore_neon-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+libcore_neon-devel %{_description}

This package contains library source intended for building other packages
which use "libcore_neon" feature of "%{crate}" crate.

%files       -n %{name}+libcore_neon-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+sleef-sys-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+sleef-sys-devel %{_description}

This package contains library source intended for building other packages
which use "sleef-sys" feature of "%{crate}" crate.

%files       -n %{name}+sleef-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Fri Sep 17 18:33:31 CEST 2021 Robert-André Mauchin <zebob.m@gmail.com> - 0.3.5-1
- Initial package