# Created by pyp2rpm-3.3.6
%global pypi_name first

Name:           python-%{pypi_name}
Version:        2.0.2
Release:        1%{?dist}
Summary:        Return the first true value of an iterable

License:        MIT
URL:            http://github.com/hynek/first/
Source0:        %{pypi_source}
BuildArch:      noarch

BuildRequires:  python3-devel
BuildRequires:  python3dist(setuptools)

%description
first: The function you always missed in Python first is an MIT-licensed Python
package with a simple function that returns the first true value from an
iterable, or None if there is none. If you need more power, you can also supply
a key function that is used to judge the truth value of the element or a
default value if None doesn’t fit your use case.N.B. I’m using the term
“true”...

%package -n     python3-%{pypi_name}
Summary:        %{summary}
%{?python_provide:%python_provide python3-%{pypi_name}}

%description -n python3-%{pypi_name}
first: The function you always missed in Python first is an MIT-licensed Python
package with a simple function that returns the first true value from an
iterable, or None if there is none. If you need more power, you can also supply
a key function that is used to judge the truth value of the element or a
default value if None doesn’t fit your use case.N.B. I’m using the term
“true”...


%prep
%autosetup -n %{pypi_name}-%{version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%build
%py3_build

%install
%py3_install

%check
%{__python3} setup.py test

%files -n python3-%{pypi_name}
%license LICENSE
%doc README.rst
%{python3_sitelib}/__pycache__/*
%{python3_sitelib}/%{pypi_name}.py
%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info

%changelog
* Thu Oct 07 2021 mockbuilder - 2.0.2-1
- Initial package.