%global namedreltag .Final
%global namedversion %{version}%{?namedreltag}
Name: hibernate-commons-annotations
Version: 5.0.1
Release: 5%{?dist}
Summary: Hibernate Annotations
# For details see:
# - https://github.com/hibernate/hibernate-commons-annotations/commit/4a902b4f97f923f9044a4127357b44fe5dc39cdc
# - https://github.com/hibernate/hibernate-commons-annotations/commit/a11c44cd65dadcedaf8981379b94a2c4e31428d1
License: LGPLv2
# Incorrect Free Software Foundation address https://hibernate.atlassian.net/browse/HCANN-78
URL: http://www.hibernate.org/
Source0: https://github.com/hibernate/hibernate-commons-annotations/archive/%{namedversion}/%{name}-%{namedversion}.tar.gz
Source1: https://repository.jboss.org/nexus/service/local/repositories/central/content/org/hibernate/common/%{name}/%{namedversion}/%{name}-%{namedversion}.pom
BuildArch: noarch
BuildRequires: maven-local
BuildRequires: mvn(junit:junit)
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
BuildRequires: mvn(org.bsc.maven:maven-processor-plugin)
BuildRequires: mvn(org.jboss.logging:jboss-logging)
BuildRequires: mvn(org.jboss.logging:jboss-logging-annotations)
BuildRequires: mvn(org.jboss.logging:jboss-logging-processor)
%description
Following the DRY (Don't Repeat Yourself) principle,
Hibernate Validator let's you express your domain
constraints once (and only once) and ensure their
compliance at various level of your system
automatically.
Common reflection code used in support of annotation processing.
%package javadoc
Summary: Javadoc for %{name}
%description javadoc
This package contains the API documentation for %{name}.
%prep
%setup -q -n hibernate-commons-annotations-%{namedversion}
# Cleanup
find . -name '*.class' -print -delete
find . -name '*.jar' -print -delete
cp %{SOURCE1} pom.xml
# Set encodig
%pom_xpath_inject pom:project "
UTF-8
UTF-8
"
# Generate logging source
%pom_add_plugin org.bsc.maven:maven-processor-plugin:2.2.4 . "
\${project.build.directory}/generated-sources/logging
org.jboss.logging.processor.apt.LoggingToolsProcessor
process
generate-sources
process
org.jboss.logging
jboss-logging-processor
2.0.1.Final
"
# Inject and configure MANIFEST items
%pom_add_plugin org.apache.maven.plugins:maven-jar-plugin:2.6 . "
\${project.build.outputDirectory}/META-INF/MANIFEST.MF
http://hibernate.org
Hibernate.org
org.hibernate
\${project.version}
org.hibernate.annotations.common.Version
"
# Add OSGi support
%pom_add_plugin org.apache.felix:maven-bundle-plugin:2.5.4 . "
true
\${project.groupId}.\${project.artifactId}
\${project.artifactId}
Hibernate.org
\${project.version}
bundle-manifest
process-classes
manifest
"
# Add missing deps
%pom_add_dep org.jboss.logging:jboss-logging-annotations:2.0.1.Final:compile
%pom_add_dep junit:junit:4.12:test
%build
%mvn_build
%install
%mvn_install
%files -f .mfiles
%doc changelog.txt readme.txt
%license lgpl.txt
%files javadoc -f .mfiles-javadoc
%license lgpl.txt
%changelog
* Fri Jul 13 2018 Fedora Release Engineering - 5.0.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Feb 07 2018 Fedora Release Engineering - 5.0.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering - 5.0.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering - 5.0.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Fri Jul 08 2016 gil cattaneo 5.0.1-1
- update to 5.0.1.Final
- add OSGi support
- remove duplicate file
* Wed Feb 03 2016 Fedora Release Engineering - 4.0.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering - 4.0.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Mon Jun 16 2014 Marek Goldmann - 4.0.4-1
- Upstream release 4.0.4.Final
* Sat Jun 07 2014 Fedora Release Engineering - 4.0.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Fri Mar 28 2014 Michael Simacek - 4.0.3-2
- Use Requires: java-headless rebuild (#1067528)
* Mon Sep 09 2013 Marek Goldmann - 4.0.3-1
- Upstream release 4.0.3.Final
* Sat Aug 03 2013 Fedora Release Engineering - 4.0.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Thu Feb 14 2013 Fedora Release Engineering - 4.0.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Wed Feb 06 2013 Java SIG - 4.0.1-3
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
- Replace maven BuildRequires with maven-local
* Thu Jul 19 2012 Fedora Release Engineering - 4.0.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Sun Apr 22 2012 gil cattaneo 4.0.1-1
- update to 4.0.1.Final
- adapt to current guideline
- add backward compatibility in depmap
* Fri Jan 13 2012 Fedora Release Engineering - 3.2.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Wed Jun 01 2011 Marek Goldmann 3.2.0-3
- Fixed license
- Using source from git
* Mon May 23 2011 Marek Goldmann 3.2.0-2
- Moved to hibernate subdirectory
* Fri May 20 2011 Marek Goldmann 3.2.0-1
- Initial packaging