# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}

%global crate wasmtime

Name:           rust-wasmtime21
Version:        21.0.2
Release:        %autorelease
Summary:        High-level API to expose the Wasmtime runtime

License:        Apache-2.0 WITH LLVM-exception
URL:            https://crates.io/crates/wasmtime
Source:         %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch:          wasmtime-fix-metadata-auto.diff

BuildRequires:  cargo-rpm-macros >= 24

ExcludeArch:    ppc64le s390x

%global _description %{expand:
High-level API to expose the Wasmtime runtime.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+addr2line-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+addr2line-devel %{_description}

This package contains library source intended for building other packages which
use the "addr2line" feature of the "%{crate}" crate.

%files       -n %{name}+addr2line-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+all-arch-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+all-arch-devel %{_description}

This package contains library source intended for building other packages which
use the "all-arch" feature of the "%{crate}" crate.

%files       -n %{name}+all-arch-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+async-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+async-devel %{_description}

This package contains library source intended for building other packages which
use the "async" feature of the "%{crate}" crate.

%files       -n %{name}+async-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+cache-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+cache-devel %{_description}

This package contains library source intended for building other packages which
use the "cache" feature of the "%{crate}" crate.

%files       -n %{name}+cache-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+component-model-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+component-model-devel %{_description}

This package contains library source intended for building other packages which
use the "component-model" feature of the "%{crate}" crate.

%files       -n %{name}+component-model-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+coredump-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+coredump-devel %{_description}

This package contains library source intended for building other packages which
use the "coredump" feature of the "%{crate}" crate.

%files       -n %{name}+coredump-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+cranelift-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+cranelift-devel %{_description}

This package contains library source intended for building other packages which
use the "cranelift" feature of the "%{crate}" crate.

%files       -n %{name}+cranelift-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+debug-builtins-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+debug-builtins-devel %{_description}

This package contains library source intended for building other packages which
use the "debug-builtins" feature of the "%{crate}" crate.

%files       -n %{name}+debug-builtins-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+demangle-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+demangle-devel %{_description}

This package contains library source intended for building other packages which
use the "demangle" feature of the "%{crate}" crate.

%files       -n %{name}+demangle-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gc-devel %{_description}

This package contains library source intended for building other packages which
use the "gc" feature of the "%{crate}" crate.

%files       -n %{name}+gc-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+incremental-cache-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+incremental-cache-devel %{_description}

This package contains library source intended for building other packages which
use the "incremental-cache" feature of the "%{crate}" crate.

%files       -n %{name}+incremental-cache-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+parallel-compilation-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+parallel-compilation-devel %{_description}

This package contains library source intended for building other packages which
use the "parallel-compilation" feature of the "%{crate}" crate.

%files       -n %{name}+parallel-compilation-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+pooling-allocator-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+pooling-allocator-devel %{_description}

This package contains library source intended for building other packages which
use the "pooling-allocator" feature of the "%{crate}" crate.

%files       -n %{name}+pooling-allocator-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+profiling-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+profiling-devel %{_description}

This package contains library source intended for building other packages which
use the "profiling" feature of the "%{crate}" crate.

%files       -n %{name}+profiling-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+runtime-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+runtime-devel %{_description}

This package contains library source intended for building other packages which
use the "runtime" feature of the "%{crate}" crate.

%files       -n %{name}+runtime-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+threads-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+threads-devel %{_description}

This package contains library source intended for building other packages which
use the "threads" feature of the "%{crate}" crate.

%files       -n %{name}+threads-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+wat-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+wat-devel %{_description}

This package contains library source intended for building other packages which
use the "wat" feature of the "%{crate}" crate.

%files       -n %{name}+wat-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+winch-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+winch-devel %{_description}

This package contains library source intended for building other packages which
use the "winch" feature of the "%{crate}" crate.

%files       -n %{name}+winch-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+wmemcheck-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+wmemcheck-devel %{_description}

This package contains library source intended for building other packages which
use the "wmemcheck" feature of the "%{crate}" crate.

%files       -n %{name}+wmemcheck-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test -- --all-targets
%endif

%changelog
%autochangelog