## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 3;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Created by pyp2rpm-3.3.4
Name:           python-zoidberg
Version:        0.1.1
Release:        %{autorelease}
Summary:        A Flux-Coordinate Independent (FCI) Grid Generator for BOUT++

License:        LGPL-3.0-or-later
URL:            http://boutproject.github.io
Source0:        %{pypi_source zoidberg}
BuildArch:      noarch

BuildRequires:  python3-devel
BuildRequires:  pyproject-rpm-macros
BuildRequires:  python3-pytest

%description
A Flux-Coordinate Independent (FCI) Grid Generator for BOUT++

%package -n     python3-zoidberg
Summary:        %{summary}

%description -n python3-zoidberg
A Flux-Coordinate Independent (FCI) Grid Generator for BOUT++

%generate_buildrequires
%pyproject_buildrequires -r


%prep
%autosetup -n zoidberg-%{version} -p 1
# Remove bundled egg-info
rm -rf zoidberg.egg-info


%build
%pyproject_wheel


%install
%pyproject_install
%pyproject_save_files zoidberg


%check
# Workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1997717
export HDF5_USE_FILE_LOCKING=FALSE
%pytest


%files -n python3-zoidberg -f %{pyproject_files}
%license LICENSE
%doc README.md
# Next version will include some binaries
# %%{_bindir}/zoidberg-*


%changelog
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

* Fri Jun 30 2023 Python Maint <python-maint@redhat.com> - 0.1.1-2
- Rebuilt for Python 3.12

* Wed Apr 12 2023 David Bold <dave@ipp.mpg.de> - 0.1.1-1
- Initial Package