## START: Set by rpmautospec
## (rpmautospec version 0.5.1)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 6;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}

%global crate etcetera

Name:           rust-etcetera
Version:        0.8.0
Release:        %autorelease
Summary:        Unopinionated library for obtaining configuration, data, cache, & other directories

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/etcetera
Source:         %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch:          etcetera-fix-metadata-auto.diff

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
An unopinionated library for obtaining configuration, data, cache, &
other directories.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Fri Oct 20 2023 Seth <sethmb@pm.me> - 0.8.0-5
- Third times the charm (fedora#2240793)

* Fri Oct 20 2023 Seth <sethmb@pm.me> - 0.8.0-4
- Second import (fedora#2240793)

* Fri Oct 20 2023 Seth <sethmb@pm.me> - 0.8.0-3
- Initial import (fedora#2240793)

* Fri Oct 20 2023 Seth <sethmb@pm.me> - 0.8.0-2
- Shipping spec

* Fri Oct 20 2023 Seth <sethmb@pm.me> - 0.8.0-1
- Initial attempt
## END: Generated by rpmautospec